Качественные модули для DLE
с приятными ценами
Важная новость, не пропустите
По данной ссылке вы можете ознакомиться с ней.
Уведомление!
Для быстрой технической поддержки доступен телеграм - https://t.me/lazydev_dle

Запись в блоге #10

Здравствуйте, прошло уже намного больше года с последней записи в блоге, пора рассказать что к чему. Отсутствовал я всё это время по разным обстоятельствам от личных до проблем со здоровьем. На данный момент я уже полноценно возвращаюсь к работе с каждым днём.

Все текущие модули получили обновления до последней версии движка а также новую документацию. Да на это ушло больше времени чем нужно было. Кроме этого некоторые модули больше не будут получать новый функционал только лишь исправления и обновления под новые версии движка. Я уже могу предоставить список этих модулей
  • DLE Filter
  • DLE Search
  • DLE Collections
  • DLE YouWatch
  • DLE Conditions
Они полностью самодостаточны с большим набором функционала, не вижу смысла добавлять что-то ещё, делая из хлеба троллейбус - особенно про первые два.

Дальше список модулей и что с ними будет.
  • DLE Seo - будет получать разного рода апдейты с новым функционалом.
  • DLE Subscribe - пока не решено до конца, либо придется его переписать полностью либо продолжить на текущем выпускать обновления с новым функционалом. Правда при первом это будет проще но потребует больше времени, при втором меньше времени но подход может быть не совсем хороший.
  • DLE Scroll News - получит обновление с рефакторингом кода, возможно также и новый функционал.
  • DLE Emote Lite - получит полноценное обновление с новым функционалом и кодом.
  • DLE List - сейчас его нет на сайте, но он был ранее и есть клиенты с ним, о нём я также не забыл. Сейчас как раз переписываю код, главное что осталось это оптимизировать запросы.

Документация модулей продолжит обновляться и дополняться - речь идёт о её содержимом а не внешнем виде.

С выходом DataLife Engine 15.3 (или 16.0 как решат разработчики), минимальная поддерживаемая версия поднимется до 15.0 ниже уже нет никакого смысла. Это не значит что модули вдруг перестанут работать, просто ниже этой версии я уже не буду проверять работоспособность обновлений.

Ближе к зиме будет поддержка PHP 8.0 и 8.1, она то и сейчас есть, проблема в Ioncube который только сейчас добавил эту поддержку, а к зиме планируются скидки на обновления.

Планируется также выпуск новых модулей, они будут уже требовать актуальную версию движка.

Бесплатные модули и плагины будут также обновлены до конца этой недели до 15.2 и не ниже. То есть, все версии ниже будут удалены.

Я также буду быстро реагировать на проблемы или баги в модулях, исправляя как можно быстрее.

Теперь все текущие модули требуют версию PHP 7.1 или выше и Ioncube Loader 11.0.0 или выше.

Клиенты Extended лицензий теперь могут скачивать их из профиля своего аккаунта, ранее модули с этой лицензией выдавались через Google Drive по запросу. Но есть одно но, не все могут это сделать из-за того что могли покупать напрямую или по другой причине. Если это про вас, то просьба отписать в телеграмм или в техническую поддержку с скриншотом транзакции или другой информацией подтверждающей это.

Ранее была чистка сообщений в технической поддержке, это была временная мера, все ранее удаленные сообщения восстановлены. Прошу прощения за это.
09.09.22
3 028
3
Комментарии (3)
  1. Aison
    Aison Клиенты
    9 сентября 2022 23:59
    +1
    Рад, что ты снова в строю)
  2. miha
    miha Клиенты
    9 сентября 2022 08:07
    -1
    Желаю успешной работы! 💯
  3. MrPechenkO
    MrPechenkO Посетители
    9 сентября 2022 05:12
    0
    С выздоровлением)
    Однозначно лайк, будем ожидать обновление модулей, а так же возможно что то новое)